Plug-In Support in Max 5
Max 5 does not support building VST plug-ins from patches. The objects used to build plug-ins are included in Max 5 and work - inside Max - as they did in the past.
The vst~ object is not compatible with VST plug-ins created with Max 4. When used on PowerPC computers on the Mac platform, the vst~ object is not compatible with certain older third-party VST plug-ins that do not support the VST 2.4 specification. By contrast, VST plug-ins that work on the Mac Intel platform should work better when hosted by vst~ in Max 5 than they did in previous versions.
As an alternative to making plug-ins out of your patches, you may wish to consider using the new features of the poly~ object. In addition to the poly~ object's new multi-processor capabilities, it can also load patchers dynamically without shutting off the audio of the enclosing patch by using the new patchername attribute. The vst~ object's ability to load new plug-ins while the audio was running was one of the primary reasons Max users converted patches into VST plug-ins. With poly~ in Max 5, this is no longer necessary.